Predator Database Requirements

Support for the following database versions are included with Predator v11 and v10 applications:

Microsoft Access Predator Application Notes
Microsoft Access 2019 Requires v11
Microsoft Access 2016 Requires v11
Microsoft Access 2013
Microsoft Access 2010
Microsoft Access 2007
Microsoft Access 2003
Microsoft Access 2002
Microsoft Access 2000

NOTE: Predator personnel are available to assist but we do not provide DBA level of support. Microsoft Access licenses do not need to be purchased.

Microsoft SQL Server Internal Predator Application Notes
Microsoft SQL Server 2019 15.0 Requires v11 with TLS option
Microsoft SQL Server 2019 Express 15.0 Requires v11 with TLS option
Microsoft SQL Server 2017 14.0 Requires v11 with TLS option
Microsoft SQL Server 2017 Express 14.0 Requires v11 with TLS option
Microsoft SQL Server 2016 13.0 Requires v11 with TLS option
Microsoft SQL Server 2016 Express 13.0 Requires v11 with TLS option
Microsoft SQL Server 2014 12.0 Version 11 or 10 with v11 TLS option
Microsoft SQL Server 2014 Express 12.0 Version 11 or 10 with v11 TLS option
Microsoft SQL Server 2012 11.0 Version 11 or 10 with no TLS support
Microsoft SQL Server 2012 Express 11.0 Version 11 or 10 with no TLS support
Microsoft SQL Server 2008 10.x Version 11 or 10 with no TLS support
Microsoft SQL Server 2008 Express 10.x Version 11 or 10 with no TLS support
Microsoft SQL Server 2005 9.0 Version 11 or 10 with no TLS support
Microsoft SQL Server 2005 Express 9.0 Version 11 or 10 with no TLS support
Microsoft SQL Server 2000 8.0 Version 11 or 10 with no TLS support

NOTE: Predator personnel are available to assist but we do not provide DBA level of support. TLS support is included as a standard v11 feature but it is optional and not required. TLS provides enhanced security between Predator applications and Microsoft SQL Server. TLS operation is recommended by Predator Software and can be implemented during the installation of each Predator application. Predator applications support database user connections via SQL authentication, integrated Windows security or a specific functional Windows user. Non Windows based applications such as Predator MDC for Android require mixed mode authentication to be enabled and a SQL user.

Oracle Database Predator Application Notes
Oracle 19c Requires v11
Oracle 18c Requires v11
Oracle 18c Express Requires v11
Oracle 12c
Oracle 11g
Oracle 11g Express
Oracle 10g
Oracle 10g Express
Oracle 9i
Oracle 9i Express
Oracle 8i
Oracle 7

NOTE: Predator personnel are available to assist but we do not provide DBA level of support. Oracle editions of Predator applications require the Oracle Database Client for Microsoft Windows (32 bit) to be installed on all appropriate PCs. Predator installs do not include the Oracle Database Client for Microsoft Windows which can be downloaded from Oracle's web site.

More Self Help Articles

90+ Self Help Articles covering a wide range of technical details, references and processes are available on this web site to help support and troubleshoot Predator application issues.